it-mure.jp.net

Adobe Flash Playerをインストールするにはどうすればよいですか?

64ビットUbuntuでフラッシュビデオを視聴する際に重大な問題が発生しました。プラットフォームでフラッシュを実行する良い方法を知っている人はいますか?

105
Steven Oxley

11.04以前の場合:

Ubuntu Software Centerからインストールしていますか?

  1. [アプリケーション]-> [Ubuntu Software Center]に移動します。
  2. Canonical Partnersをクリックします
  3. Adobe Flash Plugin 11をクリックして、インストールをクリックします。

注:これは、64ビットUbuntuインストールで使用する方法であり、まだ失敗していません。

enter image description here

81
Nathan Osman

11.10以降の場合

ランチャーからSoftware Centerを起動し、flashを検索します

2つのエントリが見つかります。 1つ目は、Adobeの32ビットフラッシュバージョンのラッパーです。 2番目は64ビットフラッシュバージョンです。

2番目のフラッシュエントリを選択します-次の図が表示されている場合は、以前にCanonical Partner Repositoryをまだ有効にしていません。

enter image description here

クリック詳細

enter image description here

...をクリックして、このソースを使用してCanonical Partner Repositoryを有効にします

enter image description here

バグレポートについてはこの回答の最後を参照してください

Installをクリックします

enter image description here

Installボタンをクリックし、プロンプトが表示されたらパスワードを入力します。注-ソフトウェアをインストールする権限が必要です。

enter image description here

インストールが続行されます。

enter image description here

完了したら、Firefoxを起動し、Flashビデオを参照します。右クリックして、最新バージョンのFlashが正しくインストールされていることを確認します。

enter image description here

注-写真は変更される可能性があります-64ビットバージョンは、Oneiricリリースの前週に最近パッケージ化されたばかりです-現在1つの問題が存在します。

  1. https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/870835

暫定的に-上の写真の最初の「Multiverse」32ビットプラグインを使用するか、Adobe-flashpluginを使用します

Sudo apt-get install Adobe-flashplugin
68
fossfreedom

これは、Firefox用のAdobe Flashプラグインをインストールする方法です。

  1. this ページに移動し、他のLinuxのオプション.tar.gzを選択します。ファイルをダウンロードします。
  2. プラグインtar.gzを解凍し、ファイルを適切な場所にコピーします。
  3. プラグインtar.gzをローカルに保存し、ファイルが保存された場所を書き留めます。
  4. ターミナルを起動し、ファイルを保存した場所にディレクトリを変更します。
  5. Tar.gzファイルを解凍します。開梱すると、次のように表示されます。

    • libflashplayer.so
    • / usr
  6. LinuxディストリビューションとFirefoxのバージョンに基づいて、ブラウザーのプラグインディレクトリの場所を特定します(通常は/usr/lib/mozilla/plugins/)。
    Forubuntu 14.04パスは:/usr/lib/firefox/browser/plugins

  7. libflashplayer.soを適切なブラウザプラグインディレクトリにコピーします。プロンプトで次を入力します。

    Sudo cp libflashplayer.so <BrowserPluginsLocation>
    
  8. Flash Playerのローカル設定の構成ファイルを/ usrディレクトリにコピーします。プロンプトで次を入力します。

    Sudo cp -r usr/* /usr
    
  9. ブラウザを再起動します。

31
ignite

あなたはubuntuを使用したのはこれが初めてだと述べたので。パッケージubuntu-restricted-extrasをインストールすることをお勧めします。これには、Adobe Flashやコーデック、MSフォントなどの便利なものがたくさん含まれています。

これはさまざまな方法で行えます。

ソフトウェアセンター:このリンクをクリックしてください:

Install via the software center

または端末で:Sudo apt-get install ubuntu-restricted-extrasと入力します

synaptic:パッケージubuntu-restricted-extrasを検索し、パッケージを右クリックしてインストールを選択し、マークを選択します。適用ボタンをクリックすると、すべてがインストールされます。

21
Terry

この問題には簡単な解決策があります。

Firefoxを開き、 Youtube に移動します。ビデオをクリックします。 Flashプレーヤーがインストールされていないため、間違いなく再生されません。しかし、Firefoxはあなたをinstall missing plug-inに昇格させます。それをクリックして、手順に従ってください。その後、ビデオの再生が開始されます。最新のFirefoxブラウザーがインストールされていることを確認してください。

または、ターミナルでこれを試してください

Sudo apt-get install flashplugin-installer
13
Kaktarua

Firefoxの Flash-Aid 拡張機能を入手してください。システムアーキテクチャに適したバージョンのダウンロードとインストールを行い、競合するプラグインも削除します。 64ビットを使用している場合は、64ビットプレビューバージョンをインストールすることもできます。これにより、nspluginwrapperを使用した32ビットよりも優れた結果が得られます。

ところで、〜/ .mozilla/pluginsフォルダーに何もコピーできない場合は、〜/ .mozillaフォルダーの所有権を確認する必要があります。そこに何でもコピーできるはずです。もちろん、ルート権限を必要とするホームディレクトリ外のシステムフォルダを参照している場合を除きます。

5
lovinglinux

使用しているブラウザによって異なります。 Google Chrome(Chromiumではない)にはデフォルトでFlashプレーヤーがあります。

Www.google.com/chromeにアクセスし、[ダウンロード]をクリックしますChrome 64ビット.debを選択します(32ビットマシンを使用してこれを読む場合は、32ビット.debを選択する必要があります)

ダウンロードした.debファイルをクリックすると、ソフトウェアセンターで開きます。今すぐインストールをクリックし、終了したら、アプリケーション->インターネットでブラウザを見つけることができます。

4
Mozart321

13.10 64ビットインストールでChromeでフラッシュを動作させるために、可能な限り多くの提案を行いました。何も機能しませんでした。私はついにPepper Flashの答えを見つけました。

(リンクは直接です)に、完全でよく書かれた指示があります

buntuhandbook.org

リポジトリの追加、aptの更新、Pepperのインストール、およびchrome構成の変更について詳しく説明します。私が彼らの指示とは違うことをしたのは、/ etc/chromium-browserディレクトリに変更してコマンドを発行することでした

Sudo gedit default

これにより、必要な.sh情報に加えてファイルにコメントを追加できるようになったため、変更されたデフォルトファイルの最後の数行は次のようになりました。

# enable Pepper Flash Player Plugin
. /usr/lib/pepflashplugin-installer/pepflashplayer.sh

このソリューションがしばらく機能することを願っています。

2
zenpistolero
Sudo apt-get remove --purge Adobe-flashplugin flashplugin* nspluginwrapper
Sudo apt-get install --reinstall Adobe-flashplugin

参照: http://ubuntuguide.net/install-Adobe-flash-pluginfix-not-working-problem-in-ubuntu-11-10-oneiric

2
Coc

「パートナー」リポジトリのAdobe-flashpluginを使用しても、FlashビデオはUbuntu 14.04の新規インストールでは再生されません— YouTubeで黒い画面になりました( HTML5を使用するように設定 を除いた場合) dailymotionなど。 freshplayerplugin (明らかにChromeのFlashプレーヤーのラッパー)をインストールすることで問題が解決しました:

Sudo add-apt-repository ppa:nilarimogard/webupd8
Sudo apt-get update
Sudo apt-get install freshplayerplugin

Ubuntuソフトウェアセンター([アプリケーション]メニュー)を使用します。 (検索ボックスの)テキスト入力フィールドで「フラッシュ」を検索すると、1つのAdobe Flashプラグインが表示されます(Adobeロゴに注意してください)。それを選択し、指示に従ってソースを使用します。

2
Daniel T Chen

どの「プラグイン」ディレクトリが使用されているかを再確認してください。私のFirefoxが実際に読んでいるものを見つけるまで、すべてのプラグインディレクトリを一回だけ掘り下げてから、共通の1つを指すようにすべてをln -sedしました。

一日の終わりには、間違った場所に落としてしまうかもしれません。

Alsoコマンドラインからfirefoxを起動すると、エラーが表示される場合があります。例は、x64ブラウザー(OSではない)でx86フラッシュプレーヤーを実行することです。コマンドライン(%> firefox)から、プラグイン初期化ログの行が表示されるはずです。 (多分最初にこれを試してください:P)

Also/usr/lib/...内のすべてのものはrootによって所有されているため、Sudo cp libflashplayer.so /usr/lib/firefox/plugin.../firefox/pluginがfirefoxプラグインディレクトリの場所を指している必要があります。

2
Dmitriy Likhten

11.10の64ビットフラッシュの明確な修正

11.10システムでラッパーを使用せずに64ビットFlashを修正しました。上記の解決策に従えば、32ビットバージョンとラッパーになります。

注:このほとんどは端末でも実行できます。その場合、Synapticをインストールする必要はありません。さらに、手順5、6、および8を実行するだけで十分かもしれませんが、これはまだテストされていません。

  1. Synapticをインストールします(Software Centerは、必要なパッケージを表示しません。メインアイテムにも技術アイテムにも、インストールした後でも表示されません)
  2. Synapticを起動し、「フラッシュ」を検索します
  3. インストール状態で並べ替え
  4. すべてのフラッシュ関連パッケージ(flashplugin-downloader:i386、flashplugin-installer、ndiswrapper-commonなど)を削除します。リストに何も表示されない場合は、おそらくFlashがまったくインストールされていません。その場合は、次のステップに進んでください。
  5. Canonicalパートナーリポジトリを有効にします(その方法については上記の投稿をご覧ください)
  6. [更新]をクリックして、パッケージリストを更新します(Software Centerがこれを行うことを期待しないでください)。
  7. 「フラッシュ」をもう一度検索します
  8. パッケージ「Adobe-flashplugin」をインストールします。リストにない場合は、パッケージリストの更新で問題が発生しました。 Synapicを終了して再起動し、「再読み込み」をクリックします。

追加のパッケージ「Adobe-flash-properties-gtk」が自動的にインストールされます。これ以上何もない。

これで、FirefoxとChromiumの両方でラッパーやその他のゴミのない完全な64ビットFlashを使用できます。ただし、ブラウザの再起動が必要です。それでも動作しない場合は、再起動してみてください(古いプラグインへの参照がどこかにある可能性があります)。

2
iGadget

必要なことは次のとおりです。デフォルトでは、Ubuntuにはオープンソースソフトウェアのみが有効になっています(とにかくそうだと思います)。

他の機能(Flash、Java、MP3の記録または再生のサポートなど、オープンソースではない)を有効にする方法は、ソフトウェアセンターに移動してメニューに移動することです(残念ながら、現在のところUbuntuではなく、 tはどのメニューかを教えて)ソフトウェアソースを検索します。

それをクリックすると、ウィンドウが表示され、Ubuntuにインストールが許可されているものが通知されます。あなたの前に5つの異なる「宇宙」のリストがあるはずです。あなたがする必要があるのは、現在有効になっていない2つを有効にすることです。

その後、リポジトリをリロードするかどうかを確認する必要がありますが、リロードしない場合は、コマンドラインで取得して入力します

Sudo apt-get update

そして終了させます。その後、Software Centerまたはコマンドラインのいずれかでフラッシュを見つけることができるはずです。または、ubuntu-restricted-extrasパッケージをインストールすることもできます。これにより、上記の3つのすべてが提供されます。

幸運を!

2
Noah

誰かを助けることを期待して、ここに投稿します。何が起きていたのか、どうやって解決したのかを説明します。

セットアップ:
WUBIインストールから12.04を実行しています。

問題:
Ubuntu Software Centerでキーワードflashを検索したところ、Mozillaのflash pluginの1つを除き、ここに投稿されたオプションはどれも表示されませんでした。インストールしようとしたときに、依存関係エラーが発生しました。

Ubuntu Software CenterのUbuntu Restricted Extrasを使用してインストールしようとしましたが、このインストールのフラッシュプラグイン部分は依存関係エラーのため機能しませんでした。

検索を続け、プラグインをインストールするためのこのコマンドを見つけました

Sudo apt-get install flashplugin-nonfree

ターミナルから実行しました。

この出力と同じ依存関係エラー:

Reading package lists... Done Building dependency tree        
Reading state information... Done Note, selecting 'flashplugin-installer' instead of 'flashplugin-nonfree' 
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. 
The following information may help to resolve the situation:
The following packages have unmet dependencies:  
 flashplugin-installer : 
 Depends: libnspr4-0d but it is not going to be installed E: Unable to correct problems, you have held broken packages.

解決策:

走った

Sudo apt-get install -f 

その後

Sudo apt-get update 

依存関係を解決しようとしていた他の投稿からそれを見つけました。

それから私は走った

Sudo apt-get install flashplugin-nonfree

flashプラグインはChromiumとFirefoxで動作するようになりました。

1
Joel

FirefoxでFlashを使用していて、Chromiumでは使用していないユーザー向けのソリューションを見つけました。それは、すべてのブラウザが独自のプラグインディレクトリを持っているという事実に基づいています。

  • / usr/lib/firefox-addons/plugins(Firefoxの場合)
  • / usr/lib/chromium-browser/plugins(Chromiumの場合)

だから、あなたがしなければならない唯一のことは、別名、一方を他方へのリンクにすることです。おそらく、すべてのプラグインはFirefoxプラグインディレクトリにありますが、次のことを確認する価値はありません。

ls -l /usr/lib/{mozilla,chromium-browser}/plugins

Firefoxがすべてのプラグインがある場合は、次を実行します。そうでない場合は、反対を行います。

Sudo rmdir /usr/lib/chromium-browser/plugins
Sudo ln -s /usr/lib/mozilla/plugins /usr/lib/chromium-browser/

最後に、変更を有効にするためにChromiumを再起動します。

おそらく、Chromium/Firefoxパッケージメンテナーに関するバグレポートを作成して、バグと簡単な解決策について警告することは悪い考えではないでしょう。

1
emi

インストール方法によって異なります。それは、tar.gzファイルまたはrpmまたはその他の方法によるものです。フラッシュを取得する方法はたくさんあります。

Download link: https://get.Adobe.com/flashplayer/

Installation instructions
-------------------------

Installing using the plugin tar.gz:
    o Unpack the plugin tar.gz and copy the files to the appropriate location.  
    o Save the plugin tar.gz locally and note the location the file was saved to.
    o Launch terminal and change directories to the location the file was saved to.
    o Unpack the tar.gz file.  Once unpacked you will see the following:
        + libflashplayer.so
        + /usr
    o Identify the location of the browser plugins directory, based on your Linux distribution and Firefox version
    o Copy libflashplayer.so to the appropriate browser plugins directory.  At the Prompt type:
        + cp libflashlayer.so <BrowserPluginsLocation>
    o Copy the Flash Player Local Settings configurations files to the /usr directory.  At the Prompt type:
        + Sudo cp -r usr/* /usr

Installing the plugin using RPM:
   o As root, enter in terminal:
          + # rpm -Uvh <rpm_package_file>
          + Click Enter key and follow prompts

Installing the standalone player:
   o Unpack the tar.gz file
   o To execute the standalone player,
          + Double-click, or 
          + Enter in terminal: ./flashplayer

ボーナス:

Uninstallation instructions
---------------------------

Manual uninstallation (for users who installed the plugin via Install script):
   o Delete libflashplayer.so binary and flashplayer.xpt file in 
   directory /home/<user>/.mozilla/plugins/

RPM uninstallation:
   o As root, enter in terminal:
          + # rpm -e flash-plugin
          + Click Enter key and follow prompts
1
Revanth Kumar

の場合

Sudo apt-get install flashplugin-nonfree

動作しません(私の場合と理由がわかりません...)、ブラウザとしてOperaを試してみてください。それは私のために働く唯一のものです。

PS:Operaブラウザーを宣伝したくないのですが、これが何らかの形で私にとってうまくいった唯一の解決策だったというだけです。

1
Remi Meier

先週、このトピックに関する多くの回答を確認しました。最後に、機能するソリューションとのリンクを見つけました。

https://ubuntu-mate.community/t/tutorial-flash-player-for-chromium-and-firefox/3598

基本的に、答えはすべてのソフトウェアソースから削除されているようで、古いバージョンをダウンロードして手動でインストールする必要があるということです

0
palbeda

LinuxはストアでAdobe Flash Playerをサポートしなくなったため、手動で行う必要があります。

Adobe flash player

これは、Chrome/Chromiumをインストールしている必要がない場合にもFirefoxでのみ検証されます。

UbuntuにAdobe Flash Playerを手動でインストールする手順があります。次の手順に従ってください。

  1. 開く このリンク 。デスクトップ環境に応じたバージョンが自動的に提案されます。

  2. 以下のスクリーンショットに示すように、.tar.gz for Linuxオプションを選択します。

    enter image description here

  3. 次に、ダウンロードボタンをクリックします(ダウンロードパスをDownloadsとして選択します簡単にアクセスできるシステム)。

  4. フォルダーのRight clickingでファイルを抽出し、Extract Hereオプションを選択します。

    file in downloads folder

  5. TerminalCTRL+ALT+Tを開き、以下のコマンドを1つずつコピーします

    5.1。 cd ../

    5.2。 cd your-pc-name(例; paper96)

    5.3。 cd Downloads(これはオプション3でファイルをダウンロードしたフォルダーです)。

    5.4。 cd flash_player_npapi_linux.x86_64(ファイル名は異なる場合があります。ファイルの名前をコピーして、ターミナルに貼り付けてください)

    5.5。 Sudo mv libflashplayer.so \/usr/lib/firefox-addons/plugins Enterキーを押して、それだけです。

    terminal commands

  6. ブラウザ(Firefox)とターミナルを閉じます。

  7. Firefoxを再起動すると、ブラウザにFlash Playerが表示されます。 このリンク にアクセスして確認します。

    new version of flash player

0
Pankaj Gautam