it-mure.jp.net

特定のプラグインが存在するかどうか、そして正しいバージョンかどうかを確認する方法

私はワードプレスのプラグインリポジトリに行くプラグインを作成しました。今、私はこの特定のプラグインがすでにインストールされていてアクティブになっていることを必要とする別のプラグイン(サブプラグインまたはあなたが呼び出すことができる子プラグイン)を作成する必要があります。

私はregister_activation_hookを使用できることを知っています。しかし、どうやってそのフックを使って確認するのですか?または、他に解決策があるのでしょうか。

1
ariefbayu

is_plugin_active() 関数があります。

他の方法は、必要なプラグインに固有の関数やクラスが存在するかどうかを確認することです。いくつかのプラグインはこれのために彼ら自身の定数を明示的に定義します、典型的にはバージョン番号や他の識別情報で。

プラグイン依存関係 のように、拡張依存関係ロジックをより一般的にするための開発がいくつかありますが、それらはこれまで広く普及していません。

3
Rarst