it-mure.jp.net

GPLとプラグイン

プラグイン開発者センターは "あなたのプラグインはGPLv2互換でなければならない"と言っています。しかし、TopsyプラグインはGPLv3の下にあることがわかりました。 http://www.gnu.org/licenses/rms-why-gplv3.html には、GPLv2とGPLv3には互換性がないと記載されています。それでこれは許されるべきですか? Topsyプラグインのコードを使いたい。それでは、私はGPLv2またはGPLv3の下で自分のプラグインをリリースすべきですか?

3
User

もしあなたが規則に従っているのなら(あなたが決してbreaking _で始めたくないのなら)、あなたが書いてリポジトリに提出するWordPressプラグインはGPLv2としてライセンスされなければなりません。 readmeファイルの例で誤って「GPL、バージョン2、またはそれ以降のバージョン」と表示されていたため、昨年は大きな議論がありました。

WordPressコアのライセンスに準拠するためにプラグインhadがバージョン2を使用してライセンスされることが指摘されると、多くのプラグインはバージョン2に再ライセンスされ、拒否されたプラグインはリポジトリから削除されます。 。残念なことに、かなりの数がレーダーの下を飛んで更新を逃しました。

私の提案は、

  1. Topsyの開発者に連絡して、プラグインを再ライセンスするか、コードの一部を使用してGPLv2の下でリリースをライセンスする明示的な許可を与えるように依頼してください。
  2. あなたのシステムでそれらのコードのどれかを使う前に、Topsyから肯定を得るまで待ってください。

Technically、TopsyはWordPressのコアライセンスに違反しており、それを追求するのはWordPress Foundationの責任です。しかしながら、あなたがあなた自身のコードを遵守し、それらがTopsyに対して行動を起こしたとしても合法的な結果を避けることを確実にするために、あなたはコード適切な方法でを使う許可を得るかと。

更新

電子メール、フォーラム、IRC、Tracでの議論の末、コアチームはWPリポジトリでホストされているすべてのプラグインはGPLv2と互換のライセンスを取得する必要があることを明らかにしました。つまり、ほとんどの場合、プラグインは明示的にGPLv2またはGPLv2 +( "またはそれ以降のバージョン")のどちらかでなければなりません。

これは誤ってプラグインコードをコアにしてしまう可能性を防ぐためです。 CoreはGPLv2 +として明示的にライセンスされているので、プロジェクトにロールインされるすべてのコードは同じ方法でライセンスされることができなければなりません。

しかし、あなたはまだあなたが個人的にホストされているプラ​​グインをGPLv3としてライセンスすることができます。これは、「またはそれ以降のバージョン」のコアの規定とはまだ互換性がありますが、別々のままです(同じ場所でホストされていないため)。

4
EAMann

これはここで明確にされました: http://core.trac.wordpress.org/browser/trunk/license.txt WordPressコアはGPLv2 +です

レポの要件「あなたのプラグインはGPLv2互換でなければならない」は任意であり、ライセンスの結果に基づくものではありません。その上、それはwordpress.orgリポジトリでのプラグインのホスティングにのみ適用され、プラグインが合法であるかどうかには関係ありません。 GPLv3プラグインは「間違って」いるわけでも、ライセンスに違反しているわけでもありません。 (それであなたの質問の最初の部分は答えられます。)

(GPL自体には、特定のバージョンに限定して明示的に条件を限定しない場合は、暗黙的に「アップグレード可能」と記載された特定の条項があります。この点について。)

GPLv2 +(「GPLv2のみ」ではない)とGPLv3コードを一緒に使用する場合、コードを解放する場合は、GPLv3を解放する必要があります。

あなたの質問に関しては:もしあなたがTopsyの一部を使用するなら、あなたがそれを解放するなら、あなたのコードはGPLv3(そして任意で後に)解放されなければなりません。

更新:WordPress.orgでは、GPLv3プラグインをレポジトリでホストすることができます(少なくとも2012年5月以降)。

https://make.wordpress.org/plugins/2012/05/11/cross-posted-from-the-main-development-blog-the/

3
WraithKenny

良い質問。技術的にはGPLv3はGPv2と互換性がありません。もしあなたがMatt Mullenwegがとるスタンスを取るなら、Topsyプラグインは間違っています。私が思うに、Mattは、彼らがGPLv2を介してそれらを再ライセンスするまで、彼がリポジトリからTopsyのプラグインを引き抜くことを知っていたならば。

ただし、Topsyに再ライセンスを強制することはできません(ただし、要求することはできますが、これが最善の選択かもしれません)。 "それは許可されるべきですか? "問題は"誰が許可を拒否しますか? "許可できないのは、Topsyを変更しようとする人だけです。もちろん、Mattはプラグインリポジトリから引っ張ってマーケティングのプレッシャーをかけることができます。しかし、そうでなければ、あるいはそのいずれかが起こるまでは...

それで、あなたは固い場所にいます。 GPLv3をライセンスすることなくTopsyコードを実際に使用することはできません。また、GPLv2と互換性がないため、WordPressプラグインを実際に作成することはできません(MattのGPLv2の解釈による)。

OTOH、そしてこれはアドバイスではありません私を考えてみれば、おそらくGPLv3の懸念を無視し、Topsyのコードを使用して、チップが落下する可能性がある場所に置く。それはあなたがこれまでに訴えられたり、誰かがあなたがそうしたことを訴えたりすることすらありそうもないです。そしてもしあなたがTopsyからやめようと思ったのなら、Mattもきっとあなたの味方になり、Topsyに市場の圧力をかけるでしょう。少なくともそれが私の推測です。 :)

2
MikeSchinkel

GPLは、あなたのコードが実行するためにオリジナルのコアを必要とするなら、それは同じライセンスに従わなければならないと言います。

ただし、コードを2つの部分に分割すると、コア機能を実行します(理想的には、どのフレームワークでも使用できます。 library()と、2番目のがwordpressおよびあなたのライブラリと相互作用するので、あなたは自分のライブラリに好きなライセンスを使用することができます。 wordpressの部分だけが同じライセンスに従う必要があります。

グーグルリーダーは(APIである)フィードを使いますが、それは別のバイナリなので、どんなライセンスも使うことができます。

2
Sudhanshu