it-mure.jp.net

thunderbirdを更新できません

最近、ubuntuリポジトリではないソースからThunderbird 3.1をインストールしました。どこから取得したか思い出せません(debとしてパッケージ化されていたと思います)が、自動更新しようとすると問題が発生します。

リポジトリを介して更新を管理するバージョンとは異なり、これは必要に応じて自動的に更新されるはずですが、問題がないように見えますが、実行しようとするとエラーが発生します。

推奨されるセキュリティと安定性のアップデートが利用可能ですが、それをインストールするために必要なシステム権限がありません。システム管理者に連絡するか、このコンピュータにソフトウェアをインストールする権限を持つアカウントから再試行してください。 Thunderbirdの最新バージョンはいつでも入手できます。 http://mozillamessaging.com/en-US/Thunderbird

TB必要な権限をrootとして開くのではなく、与える方法はありますか?

4
mlissner

いいえ。 Thunderbirdが自身を更新できるようにする唯一の方法は、それをrootとして起動するか、独自のホームフォルダー内に完全にインストールできるようにThunderbirdをビルドしたさらに別のソースを見つけることです。

最先端のアプリを実行したい場合のより良いオプションは、Launchpad PPAでビルドを行っている人を探すことです。これらは通常のSynaptic/Upgradeシステムを介して更新できます。つまり、このようなコーナーケースに陥ることはありません。たまたま Mozillaチームは、FirefoxとThunderbirdの新しいバージョンのPPAを維持しています であり、夜間も含まれています。そこからThunderbird 3.1をインストールすると、黄金色になります。

4

更新しました。ターミナル起動でThunderbird:

須藤サンダーバード

その後、問題なく更新されました

幸運を

アンソニー

0
TwoTone