it-mure.jp.net

CentOS4.8専用ホスティングサーバーに必要なBazaarと同様のバージョン管理システム

最近、コアシステムファイルが削除されたため、専用サーバーを再構築する必要がありました。しかし、それは別の話です...

再構築する前は、Bazaarを使用して、さまざまなプロジェクトをマージ、分岐、および変更をコミットしていました。今では、ホスティング会社がサーバーを5.0ではなくCentOs4.8で再構築したようです。これは以前のことだと思います。サポートスタッフによると、Bazaarは新しいOSと互換性がありません。

サポートスタッフは次のように述べています。

すべてのBazaar依存関係をインストールしましたが、たとえば依存関係がありません。

  • 依存関係の欠落:パッケージbzrにはlibc.so.6(GLIBC_2.4)が必要です

CentOSの上位バージョン用です。

私の質問はです。これは完全に真実であり、BazaarをCentos 4.8で動作させる方法はありますか?

そうでない場合、Bazaarに類似した他のバージョン管理システムはありますか?

以下は、Bazaarのインストールの試行のログです。

Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package bzr
Error: Missing Dependency: python(abi) = 2.4 is needed by package bzr
Error: Missing Dependency: rtld(GNU_HASH) is needed by package bzr
Error: Missing Dependency: libcrypto.so.6 is needed by package python-pycurl
Error: Missing Dependency: python(abi) = 2.4 is needed by package python-paramiko
Error: Missing Dependency: rtld(GNU_HASH) is needed by package python-pycurl
Error: Missing Dependency: python(abi) = 2.4 is needed by package python-pycurl
Error: Missing Dependency: libssl.so.6 is needed by package python-pycurl
Error: Missing Dependency: rtld(GNU_HASH) is needed by package python-crypto
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package python-crypto
Error: Missing Dependency: python(abi) = 2.4 is needed by package python-crypto
Error: Missing Dependency: python-abi = 2.4 is needed by package python-crypto
2
Brendan

あなたが本当にRHEL4/CentOS4に留まる必要がある場合(これについて考えて、元の投稿への私のコメントを読んでください)、少なくとも-のRPMを見つけることができます git および Mercurial in EPEL for RHEL4 。どちらもBazaarに匹敵しますが、(私が思うに)Bazaarが持っているLaunchpad統合が欠けています。

3
wzzrd

ソースからインストールできます。私にはかなりの数の依存関係がありますが、明らかにいくつかの部分はCで書かれているようです。しかし、それは特に複雑ではないようです。ここにかなり詳細な説明があります:

http://wiki.Bazaar.canonical.com/SourceDownloads

1
Eike